Home

Go Back   .: XT660.com - The #1 XT660 Resource :. > XT660 Tech Section > Performance Modifications & Enhancements > Electrics & Lighting
FAQ Calendar Search Today's Posts Mark Forums Read Main site

Google

Electrics & Lighting All discussions related to bike electric, lights, bulbs, fuses and wiring.

Reply
 
Thread Tools Display Modes
  #1  
Old 19-04-15, 17:44
Goldf1nger Goldf1nger is offline
Newbie XT-Moto
 
Join Date: Mar 2008
Location: Guildford
Posts: 8
Goldf1nger is on a distinguished road
Speedo over reading

Hi All,

My 2008 XT660R has been laid up for a year as it wouldn't start and I kinda lost interest in the poor thing for a bit. This week I have the bug again and sorted out the non starting issue (corroded terminals for RH switch gear under the tank).

I took it round the block and it seems the speedo over reads massively (3rd gear approx 30mph it thinks I am doing 108!), on tickover in 1st on the stand it reads 21mph. I have checked the pulses from the speed sensor and it appears to go between 0.4 and 4.8V about 6-8 times for 1 turn of the rear wheel, I suspect the speed sensor is faulty and I wondered if anyone else has any views on this?

Up until 2013 when it went wrong I had done 32000 miles in all weathers and have pulled apart every connector and cleaned the terminals as some were quite corroded. The speedo was working ok up to the point the bike went wrong.
  #2  
Old 22-04-15, 14:18
Kullam Kullam is offline
Junior XT-Moto
 
Join Date: Oct 2014
Location: Estonia
Posts: 21
Kullam is on a distinguished road
Looks like speedometer eeprom problem. http://www.xt660.com/showthread.php?...=kullam&page=2
  #3  
Old 06-05-15, 21:04
Goldf1nger Goldf1nger is offline
Newbie XT-Moto
 
Join Date: Mar 2008
Location: Guildford
Posts: 8
Goldf1nger is on a distinguished road
Thanks for the reply, I think it is the same as my Diag mode 7 counts up to 999 before returning to 0. Could you tell me how you fixed yours? I have searched and there are no instructions on how you reprogram the eeprom.

Last edited by Goldf1nger; 06-05-15 at 21:59.
Sponsored Links
  #4  
Old 09-05-15, 17:06
Kullam Kullam is offline
Junior XT-Moto
 
Join Date: Oct 2014
Location: Estonia
Posts: 21
Kullam is on a distinguished road
First you have to take your speedo apart, it's the hardest part because it's glued. I grinded indicator lights bottom edge little bit and after that used knife to open it carefully. If you get your speedo apart then you have to desolder display and under there is eeprom, you have to desolder it. Then you need new eeprom S24CS0 and here is eeprom dump files http://www.xt-660.de/forum/viewtopic.php?f=3&t=9590 . You also need eeprom programming tool, arduino or something. Then you need PonyProg and you have to write numbers from german forum Tausch Tacho to PonyProg, very long proces, and if you want your odo right then you need to rewrite all odo reading addresses and calculate new cheksums and new master cheksum to. After that write it to eeprom and solder eeprom and display back and test it. My friend offers repair service in ebay but i don't know is this offer active, i can ask what was price. Also found this http://www.ebay.com/itm/NEW-GENUINE-...42da20&vxp=mtr
  #5  
Old 14-05-15, 00:10
Goldf1nger Goldf1nger is offline
Newbie XT-Moto
 
Join Date: Mar 2008
Location: Guildford
Posts: 8
Goldf1nger is on a distinguished road
Thanks for all your help Kullam, it is appreciated. I think I have the missing pieces now, will try to reprogram and if not I will buy a new speedo.

Paul
  #6  
Old 15-05-15, 17:32
Kullam Kullam is offline
Junior XT-Moto
 
Join Date: Oct 2014
Location: Estonia
Posts: 21
Kullam is on a distinguished road
My friend made ebay offering active again. Here's the link: http://www.ebay.com/itm/Yamaha-XT660...339068&vxp=mtr
After repair, i can test speedos and chek everything is ok.
  #7  
Old 04-06-19, 15:19
George Gavrila George Gavrila is offline
Newbie XT-Moto
 
Join Date: Nov 2018
Location: Iasi
Posts: 2
George Gavrila is on a distinguished road
Hello,

I see that this item is some years old, but currently I have the same issue on my XT660R Yamaha from 2007, and it looks like I have to re-write the eeprom as you describe there.
Unfortunately it looks like the EEPROM dump files which you mentioned there are no longer available at the link. Is there any chance to help me with that?

Or is there any chance to send it to someone for this repair?

Thank you in advance,

Last edited by George Gavrila; 04-06-19 at 15:33.
Reply

Tags
660r speed sensor

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 15:05.
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.

  XT660         Archive   Main site


Footer
vBSkinworks Top